Delayed Payment Allocation for SEK Transactions

Incident Report for Billie

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 07:27 UTC

Monitoring

We did receive all missing payments from the banking provider and allocated them to the respective invoices. Affected customers should receive a payment confirmation anytime soon. We will continue monitoring the overall situation in the Swedish market for a while before closing this incident.
Posted Aug 20, 2026 - 09:01 UTC

Update

We are still waiting for a statement and resolution from our banking provider. Billie has temporarily paused dunning reminders for the Swedish market while we await further information.
Posted Aug 19, 2026 - 06:51 UTC

Identified

The issue has been identified as an incident of a third-party in our core-banking setup
Posted Aug 17, 2026 - 13:48 UTC

Investigating

We are investigating a delay in allocating some incoming SEK payments to customer accounts, which may cause affected invoices to appear as outstanding even though payment was sent.
Posted Aug 17, 2026 - 12:22 UTC